alternator - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > HemiTruckClub Drivers Lounge (Community Discussions)

Reply
 
Thread Tools Display Modes
 
Old 07-17-2012, 06:25 PM   #1
Member
 
08blueram's Avatar
 
Join Date: Sep 2008
Location: Melbourne, Florida
Posts: 52
Don't know if I am posting this in the right place but here it goes I needed a new alternator and someone nice enough to give a 2005 durango 160amp off a 5.7 will this work on my 08 ram 5.7 thanks in advance nick

__________________
Flowmasters,double 15% tint up front 5% in the rear, 2 10" subs and 1,000 watt amp,K&N drop in filter
got the chrome 20's finally

08blueram is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-17-2012, 06:25 PM   #2
Member
 
08blueram's Avatar
 
Join Date: Sep 2008
Location: Melbourne, Florida
Posts: 52
Don't know if I am posting this in the right place but here it goes I needed a new alternator and someone nice enough to give a 2005 durango 160amp off a 5.7 will this work on my 08 ram 5.7 thanks in advance nick
__________________
Flowmasters,double 15% tint up front 5% in the rear, 2 10" subs and 1,000 watt amp,K&N drop in filter
got the chrome 20's finally

08blueram is offline   Reply With Quote
Old 07-17-2012, 06:31 PM   #3
Retired BOD - Doug
 
RANCHER's Avatar
 
Join Date: Jul 2004
Location: Emory, Texas
Posts: 39,639
Garage
With you being in Florida I would check with the guys in the Florida Chapter. They have done so much work on their engines they can take them apart and put them back together blindfolded.

I think it will work if the mount is the same.
__________________

RANCHER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-17-2012, 07:23 PM   #4
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
Probably a direct fit. If my alternator ever goes away a 160 is in the mix. To be sure, check out one of the big-box parts houses and compare part numbers.
__________________
MikeHTally is offline   Reply With Quote
Old 07-17-2012, 08:56 PM   #5
Member
 
08blueram's Avatar
 
Join Date: Sep 2008
Location: Melbourne, Florida
Posts: 52
Thanks I think its a blessing that it went out I need more amps for my cb lol
__________________
Flowmasters,double 15% tint up front 5% in the rear, 2 10" subs and 1,000 watt amp,K&N drop in filter
got the chrome 20's finally

08blueram is offline   Reply With Quote
Old 07-17-2012, 10:43 PM   #6
Junior Member
 
drakelouis29's Avatar
 
Join Date: Jul 2012
Location: mumbai
Posts: 12
i think you should go with v
5.7L '06-'03 136-140 AMP BOSCH UNIT - ALTERNATOR 13985 because my uncle uses the same for his truck. it really improves the performance of the truck.
__________________
Used Trucks
drakelouis29 is offline   Reply With Quote
Old 07-18-2012, 02:16 PM   #7
Member
 
08blueram's Avatar
 
Join Date: Sep 2008
Location: Melbourne, Florida
Posts: 52
Well it doesn't work wrong plug and throws a code if you change it
__________________
Flowmasters,double 15% tint up front 5% in the rear, 2 10" subs and 1,000 watt amp,K&N drop in filter
got the chrome 20's finally

08blueram is offline   Reply With Quote
Old 07-18-2012, 02:39 PM   #8
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
Quote:
Originally posted by 08blueram:
Thanks I think its a blessing that it went out I need more amps for my cb lol
Don't look now, but your CB will never draw enough current to make the alternator break a sweat. Your audio system draws more current.
__________________
MikeHTally is offline   Reply With Quote
Old 07-18-2012, 05:20 PM   #9
Senior Member
 
mindy's hemi "Satch"'s Avatar
 
Join Date: Jun 2004
Location: Deltona, Florida
Posts: 2,171
Just had to replace mine. 2nd time first time was for bearing squeal, never really failed but replaced it anyway. This time for some reason the small connector that goes back to PCM burnt and melted, think diodes shorted. But I went back to NAPA and got replacement for $60.00 as the one I bought from them had a 3 year warranty but the guy at shop called and got me a deal as mine was 4 years, they now offer lifetime warranty. But if anyone can tell me where to get the connector that attaches to the alternator I would appreciate it.
__________________
mindy's hemi "Satch" is offline   Reply With Quote
Old 07-19-2012, 03:43 AM   #10
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,428
dealer
Quote:
Originally posted by mindy's hemi "Satch":
Just had to replace mine. 2nd time first time was for bearing squeal, never really failed but replaced it anyway. This time for some reason the small connector that goes back to PCM burnt and melted, think diodes shorted. But I went back to NAPA and got replacement for $60.00 as the one I bought from them had a 3 year warranty but the guy at shop called and got me a deal as mine was 4 years, they now offer lifetime warranty. But if anyone can tell me where to get the connector that attaches to the alternator I would appreciate it.
__________________
boedacres is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.