new member from tenn - Hemi Truck Club
 
Go Back   Hemi Truck Club > HemiTruckClub Community Forums > New Member Introductions

Reply
 
Thread Tools Display Modes
 
Old 03-02-2010, 10:09 AM   #1
Junior Member
 
Join Date: Mar 2010
Location: Dover, TN
Posts: 23
new member from tenn

07 dodge qc 4x4 hemi hard bed cover only mod done had it for a week and love it so far.acts a little sluggish on take off.

riverrathemi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-02-2010, 10:26 AM   #2
HEMIRAM07
Guest
 
Posts: n/a
new member from tenn

and
  Reply With Quote
Old 03-02-2010, 11:02 AM   #3
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
new member from tenn

Superjay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-02-2010, 12:02 PM   #4
Senior Member
 
BikerEric's Avatar
 
Join Date: Feb 2009
Location: In the wind (Peoples Republic of Maryland)
Posts: 1,229
new member from tenn

BikerEric is offline   Reply With Quote
Old 03-02-2010, 12:03 PM   #5
Steve
 
deke6520's Avatar
 
Join Date: Feb 2010
Location: Alberta, Canada
Posts: 803
Garage
new member from tenn

deke6520 is offline   Reply With Quote
Old 03-02-2010, 12:33 PM   #6
Senior Member
 
MDSBigPaPa's Avatar
 
Join Date: Sep 2007
Location: Lima, NY
Posts: 5,052
new member from tenn

Quote:
quote:Originally posted by riverrathemi:
07 dodge qc 4x4 hemi hard bed cover only mod done had it for a week and love it so far.acts a little sluggish on take off.
riverrathemi,

Couple of things to try:
1) How many miles? Throttle body may need cleaning.
2) Recalibrate your throttle: Turn key to ON (do NOT start), mash the throttle and hold for 10 seconds. With throttle still at the floor, turn key to Off and wait another 10 seconds. Slowly release the throttle.
MDSBigPaPa is offline   Reply With Quote
Old 03-02-2010, 12:34 PM   #7
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
new member from tenn

Welcome aboard riverrathemi - we're glad you joined us!
MrHemi is offline   Reply With Quote
Old 03-02-2010, 12:41 PM   #8
Senior Member
 
spainy79's Avatar
 
Join Date: Jan 2008
Location: Sullivan, IN
Posts: 3,655
Garage
new member from tenn

spainy79 is offline   Reply With Quote
Old 03-02-2010, 12:59 PM   #9
Senior Member
 
lisahemi315's Avatar
 
Join Date: Aug 2008
Location: Rotterdam, New York
Posts: 908
new member from tenn

Quote:
quote:Originally posted by MDSBigPaPa:
Quote:
quote:Originally posted by riverrathemi:
07 dodge qc 4x4 hemi hard bed cover only mod done had it for a week and love it so far.acts a little sluggish on take off.
riverrathemi,

Couple of things to try:
1) How many miles? Throttle body may need cleaning.
2) Recalibrate your throttle: Turn key to ON (do NOT start), mash the throttle and hold for 10 seconds. With throttle still at the floor, turn key to Off and wait another 10 seconds. Slowly release the throttle.
I agree with MDS....throttle body for sure.... oh and
lisahemi315 is offline   Reply With Quote
Old 03-02-2010, 01:18 PM   #10
&quotRANCHER&quot
Guest
 
Posts: n/a
new member from tenn

Welcome riverrathemi, glad to have ya aboard!

If you can try to make the GTG in Pigeon Forge in June you can meet a few of our membes.
  Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.