RB 383 main - Hemi Truck Club
 
Go Back   Hemi Truck Club > HEMI | Trucks and Special Editions > Other Vehicles

Reply
 
Thread Tools Display Modes
 
Old 08-26-2009, 01:24 AM   #1
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

As you may know, I recently aquired a 1972 Dodge Challenger with a 383 in it.

After it arrived in my garage, I noticed a significant oil leak.

After talking to the previous owner, he stated the car has leakd since he bought it nearly 3 years ago.

He said he's been looking for a way to fix the one piece rear main and everyone he's talked to says that's typical of those big old Mopars.

Does anyone make a good 2 piece seal for these old beasts? I figure some of you "old skool" Muscle Car guys would have the answer for me.

4x4HEMIrig is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-26-2009, 07:55 AM   #2
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
RB 383 main

Hate to tell u this, but it is already a two piece, four piece if ya count the side seals. It will be mess-ie, but try to clean the underneath, and be sure where the oil is coming from. If it's the original motor, it came with a Windage tray. It's oil pan, gasket, Windage tray, second oil pan gasket, block. Because of the two gaskets, leaks where common there. Also ck the oil pressure sending unit/line.
Superjay is offline   Reply With Quote
Old 09-03-2009, 11:43 PM   #3
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

Thanks Jay. It just goes to show the last owner wasn't a Mopar guy. At least I had something to start with. I'm on Mopar Muscle's forum about it too. I'm wondering how I can track down the 318 it came with and the fender tag. They could be helpful in the future.
4x4HEMIrig is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-04-2009, 08:58 AM   #4
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
RB 383 main

Quote:
quote:w/ slapstick 4 speed auto.
No, no it isn"t.
Superjay is offline   Reply With Quote
Old 09-04-2009, 11:15 AM   #5
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

Ah! 3 speed.
4x4HEMIrig is offline   Reply With Quote
Old 09-04-2009, 11:16 AM   #6
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
RB 383 main

Quote:
quote:Ah! 3 speed.
Superjay is offline   Reply With Quote
Old 09-04-2009, 11:34 AM   #7
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

It has been fixed in my sig line. I kept wondering why it wouldn't shift to 4th.
4x4HEMIrig is offline   Reply With Quote
Old 12-02-2009, 10:34 PM   #8
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

Okay, so, my alternator decided to the bed. I replaced the alternator and fabed a new bracket . Tried to start the motor and nothing . It seems like it's not getting any fuel . (mind you it's between 20 and 45 degrees in my garage due to hunting season). I put some sta-bil and some heet in the tank. thinking that would help, but no . I know the el-cheapo carquest battery doesn't help . I have an optima red-top and a save-a-battery system on my christmas list . The only other thing I can think of is power to the fuel pump . ... What do you guys think? This message has been edited. Last edited by: 4x4HEMIrig, document.write(''+ myTimeZone('Thu, 03 Dec 2009 16:31:34 GMT-0800', '03 December 2009 07:31 PM')+''); 03 December 2009 07:31 PM
4x4HEMIrig is offline   Reply With Quote
Old 12-03-2009, 08:31 AM   #9
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
RB 383 main

Quote:
quoteower to the fuel filter
What-cha mean, Vern.
Superjay is offline   Reply With Quote
Old 12-03-2009, 06:30 PM   #10
Senior Member
 
4x4HEMIrig's Avatar
 
Join Date: Jan 2006
Location: Bozeman, MT
Posts: 368
RB 383 main

Sorry Jay, I was practically asleep when I wrote that. I meant the fuel pump .
4x4HEMIrig is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.