wifey's 02 chevy trail blazer 4x4 - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Drivetrain, Differential and Transmission

Reply
 
Thread Tools Display Modes
 
Old 07-21-2013, 08:09 AM   #1
Senior Member
 
Bama's Avatar
 
Join Date: Nov 2006
Location: Baltimore, MD
Posts: 332
Garage
wifey's 02 chevy trail blazer 4x4

blowing motor oil on driverside front. driver side drive axle boot is soaked, oil dripping. Top of strut (shock) mount soaked. oil drain & block bolts dry. It smells like fresh motor oil (changed 500 miles ago). fresh gear oil smells different. Ok my son-n-law just told me it was the power steering line leaking. Does power steering fluid smell like motor oil?

__________________
06 RAM 1500 QC 4x4: SI/DO flowmaster 40 series, , AFE long tube, SC 3815, Amsoil for the HEMI
Bama is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-21-2013, 09:04 AM   #2
Senior Member
 
MikeHTally's Avatar
 
Join Date: Aug 2007
Location: Tallahassee, FL
Posts: 5,452
Garage
I think most manufacturers use tranny fluid these days. Chrysler certainly does. Even if they still used PS fluid, I don't think it'll smell like motor oil. Could it be blowing out of the filler or the PCV valve?
__________________
MikeHTally is offline   Reply With Quote
Old 07-21-2013, 06:04 PM   #3
2012 Truck of the Year
Engine Specialist
 
charged392's Avatar
 
Join Date: May 2011
Location: Fort pierce, FL
Posts: 17,234
Garage
The axle seals love to leak on those trucks but that **** stinks

Power steering fluid smells diff from oil for sure clean it all off and run it see if anything leaks right away if not drive for 50 miles check again best way to test also check levels obviously what's going down if its dripping something should be getting lower

Another very common issue with the trailblazer is the wonderful water pump leaks,fan clutch failures and broken ps input shaft belt side
__________________
"CMR TUNER" [email protected] 1/4 with a 7.32 1/8 custom long/short bars by "Me" Turbocharged 392 on 9psi S475/96/1.32 . Running thru an A518! [email protected]
charged392 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-22-2013, 05:20 AM   #4
Senior Member
 
boedacres's Avatar
 
Join Date: Nov 2008
Location: Catawissa, Missouri
Posts: 3,428
make shure it doesn't have two filter gaskets.
__________________
boedacres is offline   Reply With Quote
Old 07-27-2013, 07:29 AM   #5
Senior Member
 
Bama's Avatar
 
Join Date: Nov 2006
Location: Baltimore, MD
Posts: 332
Garage
thanks for the reply's guy's. 2 high pressure lines rusted clean through.. going in for repairs today.. HTC.com rules!!!
__________________
06 RAM 1500 QC 4x4: SI/DO flowmaster 40 series, , AFE long tube, SC 3815, Amsoil for the HEMI
Bama is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 08:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.