1993 Ford E150 tranny problem - Hemi Truck Club
 
Go Back   Hemi Truck Club > Technical Forums > Drivetrain, Differential and Transmission

Reply
 
Thread Tools Display Modes
 
Old 04-03-2005, 09:53 PM   #1
 
Join Date: Feb 2005
Posts: 47
1993 Ford E150 tranny problem

The van has a 4.9, auto. The transmission shifts into 2nd and 3rd gear right away. I've checked out the passing gear cable and the vacuum hose and both are ok. Could it be the modulator?

finnuts is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-04-2005, 06:43 AM   #2
Director Emeritus
 
MrHemi's Avatar
 
Join Date: Jun 2004
Location: Western NC
Posts: 40,856
Garage
1993 Ford E150 tranny problem

Superjay? Any ideas?
MrHemi is offline   Reply With Quote
Old 04-04-2005, 09:26 AM   #3
Board of Directors (Jay)
 
Superjay's Avatar
 
Join Date: Jun 2004
Location: Isle of Palms, SC
Posts: 43,454
1993 Ford E150 tranny problem

Sorry, no can help on that one.
Superjay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-05-2005, 09:15 AM   #4
 
Join Date: Dec 2004
Posts: 494
1993 Ford E150 tranny problem

pm me some more info as to what kind of trans, what's recently been done, etc and I'll see if I can help.
Twist 2 Go is offline   Reply With Quote
Old 04-05-2005, 09:11 PM   #5
 
Join Date: Feb 2005
Posts: 47
1993 Ford E150 tranny problem

The trans is the old c-6 three speed. I bought the van with 149 k miles on it a few years ago and now it's got 189 k miles, and I dont know if the previous owner ever had any work done to it. I can shift it manually with no problems. I also changed the fluid, it was pretty dirty and i couldnt tell if there was any metal fragments in it.
finnuts is offline   Reply With Quote
Old 04-06-2005, 05:58 AM   #6
 
Join Date: Dec 2004
Posts: 494
1993 Ford E150 tranny problem

Sounds like a modulator valve. Also, make sure you used the correct fluid in it. It should take Dextron/Mercon fluid.
Twist 2 Go is offline   Reply With Quote
Old 04-06-2005, 08:31 PM   #7
 
Join Date: Feb 2005
Posts: 47
1993 Ford E150 tranny problem

Yea it's got dex-mec in it but from the looks of the drained fluid, I think its seen it's day. Can I replace the modulator without pulling the pan? Thanks for all the advise!!!
finnuts is offline   Reply With Quote
Old 04-06-2005, 09:59 PM   #8
 
Join Date: Dec 2004
Posts: 494
1993 Ford E150 tranny problem

yes, you can. remove the vacuum hose and the one bolt for the holddown bracket. pull the modulator valve out and there will be a short metal pin about 1-1/2" long on the end of it. Don't lose it and make sure you reinstall it. If the fluid is really dirty, you might want to change it again and drain the torque converter as well. there will be a drain plug onthe front of it that can be accessed through the small plate at the bottom of the bellhousing. Hope this helps.
Twist 2 Go is offline   Reply With Quote
Old 04-07-2005, 05:29 PM   #9
 
Join Date: Feb 2005
Posts: 47
1993 Ford E150 tranny problem

Thanks Twist 2 Go. I'll check it out over the week end and hope for the best. Have a good one!
finnuts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:47 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.