Radio "glitches" - Hemi Truck Club
 
Go Back   Hemi Truck Club > General Maintenance | Owner Info > Mobile Electronics and Entertainment Systems

Reply
 
Thread Tools Display Modes
 
Old 03-31-2012, 02:50 PM   #1
Junior Member
 
CowgirlRedd's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 3
I recently purchased a 2009 1500 with the CD/DVD/Satellite Radio/Hard Drive with the touch screen. The first few days I had it we had unseasonably warm weather and I never had no issues with the radio. The last few days it's been chilly (not below freezing, but in the 30s to 40s) and I've been having some odd issues with the radio. The touch screen with "freeze", the volume will not change and I cannot turn the unit off. It will run for a minute or so like that, then the unit shuts itself down, "re boots" and works fine for a few minutes. This will happen every 3 to 5 minutes while driving. Unfortunately I have not had the need to drive it longer than about 20 minutes lately, and the interior never quite warms all the way up (ie, the dash and other hard surfaces are chilly to the touch). so, I am not sure if this is an issue I need to take up with the dealer I purchased it from (it's a bit of a drive away), if its related to the hard drive and the cooler temperatures, if I just need to get a new radio.... etc I have unfortunately not been able to call the dealership to check on getting it replaced/diagnosed yet. I figured if I could get a "quick fix" or if I knew what was going on I'd be better off. If anyone has had any experience with anything like this or has suggestions I'd appreciate any insight.

As a side note, I have also not tried pulling the fuse to re-set it yet, that's my next mission this afternoon. '

Thanks!!!
Attached Images
File Type: jpg Blue_Compressed.jpg (28.6 KB, 22 views)

__________________
There's something about the outside of a horse that's good for the inside of a man...
CowgirlRedd is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-31-2012, 02:50 PM   #2
Junior Member
 
CowgirlRedd's Avatar
 
Join Date: Mar 2012
Location: Michigan
Posts: 3
I recently purchased a 2009 1500 with the CD/DVD/Satellite Radio/Hard Drive with the touch screen. The first few days I had it we had unseasonably warm weather and I never had no issues with the radio. The last few days it's been chilly (not below freezing, but in the 30s to 40s) and I've been having some odd issues with the radio. The touch screen with "freeze", the volume will not change and I cannot turn the unit off. It will run for a minute or so like that, then the unit shuts itself down, "re boots" and works fine for a few minutes. This will happen every 3 to 5 minutes while driving. Unfortunately I have not had the need to drive it longer than about 20 minutes lately, and the interior never quite warms all the way up (ie, the dash and other hard surfaces are chilly to the touch). so, I am not sure if this is an issue I need to take up with the dealer I purchased it from (it's a bit of a drive away), if its related to the hard drive and the cooler temperatures, if I just need to get a new radio.... etc I have unfortunately not been able to call the dealership to check on getting it replaced/diagnosed yet. I figured if I could get a "quick fix" or if I knew what was going on I'd be better off. If anyone has had any experience with anything like this or has suggestions I'd appreciate any insight.

As a side note, I have also not tried pulling the fuse to re-set it yet, that's my next mission this afternoon. '

Thanks!!!
__________________
There's something about the outside of a horse that's good for the inside of a man...
CowgirlRedd is offline   Reply With Quote
Old 04-06-2012, 07:54 PM   #3
Senior Member
 
rdsetgo's Avatar
 
Join Date: Oct 2008
Location: North Pole, Alaska
Posts: 10,010
It is a bad radio I hope you are still under warrenty! I had the samething happen to mine and they had to replace my radio.
__________________
CURRENTLY OWN 2012 Ram 2500 4X4 Crew Cab Laramie Cummins and 2013 Dodge Durango AWD Citadel HEMI!!

GONE 2010 Dodge Ram 2500 4x4 Big Horn Crew Cab HEMI, 2011 Dodge Durango AWD Crew HEMI, 2007 Dodge Ram 1500 Big Horn 4x4 Quad Cab HEMI, 2008 Dodge Durango SLT 4x4 HEMI, and my First 2004 Dodge Ram 1500 Quad Cab HEMI

2010 HTC NASCAR Champion



April 25, 2007!!
rdsetgo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.