Pioneer 6x9 Issue - Hemi Truck Club
 
Go Back   Hemi Truck Club > General Maintenance | Owner Info > Mobile Electronics and Entertainment Systems

Reply
 
Thread Tools Display Modes
 
Old 02-03-2009, 06:42 PM   #1
Senior Member
 
04LaramieQC's Avatar
 
Join Date: Jan 2008
Location: Baton Rouge, LA
Posts: 861
Pioneer 6x9 Issue

Ok audio gurus, I just got some pretty nice Pioneer 6x9's but I can't get them to hit like it seems they should. I have a quad cab with the Infinity 7-speaker setup, and the Pioneers seem pretty nice, they are 300 watts with a huge magnet, way bigger than the Infinity's. They will come on and sound decent, but the stock speakers are definitely much louder, throughout all ranges. I have tried the wires both ways, so I don't think incorrect polarity is the issue. Do I just need an amp to push them or what? I got them for free so I'm not really out anything, but I'm pretty disappointed if that's all I'm going to get out of them.

04LaramieQC is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2009, 06:54 PM   #2
Senior Member
 
rdsetgo's Avatar
 
Join Date: Oct 2008
Location: North Pole, Alaska
Posts: 10,010
Pioneer 6x9 Issue

I think that you need to add an amp!
rdsetgo is offline   Reply With Quote
Old 02-03-2009, 08:22 PM   #3
Senior Member
 
Shifterbrains's Avatar
 
Join Date: Dec 2007
Location: Parkersburg, WV
Posts: 1,581
Pioneer 6x9 Issue

My Pioneers are replacements for the base Panasonic speakers,and I didn't have a sensitivity difference. Maybe Infinitys are just way sensitive.
Shifterbrains is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2009, 10:23 PM   #4
Senior Member
 
whitelight's Avatar
 
Join Date: Jan 2005
Location: Los Angeles, CA
Posts: 4,847
Pioneer 6x9 Issue

You need a pretty healthy sized amp for those things, bro. Feed them 150-200 watts each. The stock infinity amp is probably underdriving them which might actually damage them.
whitelight is offline   Reply With Quote
Old 02-03-2009, 10:46 PM   #5
Senior Member
 
04LaramieQC's Avatar
 
Join Date: Jan 2008
Location: Baton Rouge, LA
Posts: 861
Pioneer 6x9 Issue

^^Thanks man, just the info I needed. Guess I'll pull 'em out till the whole system gets an overhaul here in a month or two.
04LaramieQC is offline   Reply With Quote
Old 02-04-2009, 06:37 AM   #6
Senior Member
 
brand_x_racing's Avatar
 
Join Date: Jan 2008
Location: Spring, TX
Posts: 1,607
Pioneer 6x9 Issue

Quote:
quote:Originally posted by whitelight:
You need a pretty healthy sized amp for those things, bro. Feed them 150-200 watts each. The stock infinity amp is probably underdriving them which might actually damage them.
I agree!
brand_x_racing is offline   Reply With Quote
Old 02-05-2009, 04:56 PM   #7
Member
 
Join Date: May 2005
Location: Western PA
Posts: 67
Pioneer 6x9 Issue

Sounds like you bought the wrong ohm speakers if you want to use them with the Infinity setup.
topgun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Premium Vendor Showcase
n2 Speed Edge InTune Edge OCPerformance Parts

All times are GMT -6. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.